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Client and RTD Installation Instructions

This guide will show you how to install and set up:
1. TheRIT Client
2. The RTD Links
3. The RTD update (throttle) interval in Excel

1. RIT User Application

The client software should be installed on all workstations accessing the instructor’s workstation
(or the server running the market).

Please follow the steps described below to install the RIT Client

Step 1
Go to https://inside.rotman.utoronto.ca/financelab /rit-downloads/

Under the “Download Instructions” - Step 1, click on the “Click here” box to download the RIT
User Application.

Click here
To download RIT Market Simulator Client Application

Step 2
In the new page that has been opened, click on “Download RIT 2.0 Client”

Rotman School of Management
RIT 2.0 Client

Name: RIT 2.0 Client
Version: 1.1.8

Publisher: Rotman

I\ Download RIT 2.0 Client ||
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Step 3
Once you click on the “Download RIT 2.0 Client” button, you will notice that “click.application”

file is downloaded. Depending on the web browser, it may ask you whether you want to keep
downloading the file. If this is the case, click on “Keep” in order to successfully download the
file. Once the file is downloaded, simply click on the file to proceed with installation.

Notes for instructors, the server and client can be installed on the same computer.
2. RTD Links

In addition to the RIT Client, the computer needs an MSI file installed (The RTD/API Data Link).
This doesn’t automatically update, but it really won’t be changed frequently if ever. This registers
some DLLs and allows for communication between RIT and Excel. You can download the RTD/API
Data Link at the following link https://inside.rotman.utoronto.ca/financelab/rit-downloads/

Please note that there are 2 files, 32bit and 64bit, you need to install the file according to your Excel
version. If you don’t know which version of Office you are using, please follow the instructions
below:

In Office 2013
1. Open Excel.
2. Click File > Account.
3. Click on About Excel.

Product Information

] Office
Product Activated
Micre: ice Professional Plus 2013

In Office 2010
1. Open Excel.
2. Click File > Help.
3. Under About Microsoft Excel the version is listed with the platform, similar to this:

Version: 14.0.0000.0000 (32-bit)

Please note that you can have a 32bit Office version even if your OS is 64bit and vice versa.
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Please follow the steps described below to install the RTD Links

Step 1
Go to https://inside.rotman.utoronto.ca/financelab /rit-downloads/

Under the “Download Instructions” - Step 3, click on the correct version of the RTD Links
depending on the version of Excel that you have on your PC.

the RTD

Time Data) Links

1 (v 0.15)

3 32-bit version of RTD links
Click Here

: 64-bit version of RTD links
Click Here

Step 2
Once you click on the link described in Step 1, you will download a file called “RIT2.APL.LRTD.Link".

Double click on it and then select “Run”

Cpen File - Security Warning

The publisher could not be verified. Are you sure you want to
run this scftware?

Name: ..abadmin\Downloads\RIT2. APLRTD, Link-0.0.3.msi
Publisher: Unknown Publisher

Type: Windows Installer Package
From: C\Users\finlabadmin\Downloads\RIT2.APLRTD.L...

I Run I Cancel

[V] Always ask before opening this file

K Fa | This file does not have a valid digital signature that verfies its
Q publisher. You should only run software from publishers you trust.
= How can | decide what software to un?

Step 3
On the following window, click on “Next”

14 RIT RTD Excel Link = ®

Welcome to the RIT RTD Excel Link Setup Wizard o

The installer will guide you tiough the steps required ta install RIT ATD Excal Link on your
computer

WARMING: This computer program is protected by copyriaht law and intemationl treaties
Unauthorized duplication or distribution of this program, or any partion of it, may result in severs civil
or ciminal penalies, and will be prosecuted to the marimum extent possible under the law.
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Step 4
Choose the folder where to install the RTD Links and then start the installation.

5 RIT RTD Excel Link

Select Installation Folder A

The installer will install RIT RTD Excel Link to the following folder,

To install in this folder, click "Next”. To install to a different folder, enter it below or click "Browse"

Ealder:

C:%Program Files [#86AUzersRIT RTD Excel Link', Browse...

Install RIT RTD Excel Link for yourself. or for anyone who uses this computer:

@ Everyone

) dust me

Cancel ] { < Back J [ Mext »

Step 5
Once the installation is complete, you will see the following window.

5 RIT RTD Excel Link

Installation Complete =]

RIT RTD Excel Link has been successtully installed

Click "Close™ to exit

Please use \Windows Update to check for any ciitical updates to the MET Framework.

Cancel <Back
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When installing a new version of the RIT Excel RTD/API Links, it is highly recommended that you
uninstall any previous versions. In order to do so, please follow these steps:

1. From the Control Panel in Windows, navigate to Programs and Features and choose
Uninstall or change a program.

[E8 Al Control Panel Items - m]
“ ~ 4 [EF » Control Panel » All Control Panel ltems v O Search Co.. @
Adjust your computer's settings View by:  Small icons =
555 Administrative Tools g AutoPlay W Backup and Restare (Windows 7)
D¢ BitLocker Drive Encryption EH Color Management [E Credential Manager
¥ Date and Time E Default Programs & Device Manager
&) Devices and Printers = Display '@' Ease of Access Center |
=] File Explorer Options & File History Flash Player (32-bit)
A Fonts 4 HomeGroup & Indexing Options
[§ infrared B3 intel® HD Graphics Internet Options |
(] Java (32-bit) Keyboard € Language
Lenove - Microphone Mute 3 Mail @ Mouse
5 Metwork and Sharing Center )’ Pen and Touch ﬁ Desonzlization
{Z] Phone and Modem 5 Power Opticns B Programs and Features |
= Realtek HD Audic Manager @ Recovery ¥ Region
5 RemoteApp and Desktop Connections ¥ Security and Maintenance i Sound
@ Speech Recognition & Storage Spaces @ Sync Center
= System ﬂ Taskbar and Navigation [ Troubleshooting
82, User Accounts Ea Windows Defender @ Windows Firewall
@_ Windows Mobility Center EL Windows To Go [ Work Folders
|

2. Find the program named RIT 2.0 RTD API Link or RIT x64 RTD API Link and choose

Uninstall.
[ Programs and Features - O X
&« “ 4 [@ » ControlPanel » All Control Panel ltems » Programs and Features ~ 0 Search Pr.. 0
Control Panel Home .
Uninstall or change a program
View installed updates To uninstall a program, select it from the list and then click Uninstall, Change, or Repair.
G Turn Windows features on or
off Organize ~ = @
Mame Publisher Ins
@ Mozilla Firefox 46.0.1 (x86 en-US) Mozilla 7z
L5 Mozilla Maintenance Service Mozilla 72
OOpEnVPN 2.3.8-1601 7z
[:|PeazZip 5.7.2 Giorgio Tani 91
[5=]Pharos (e
l pealtel Hioh Nefigition Audic Nriver Bealtek Semicondyctor Corn 877
[E=IRIT x64 2.0 RTD APl Link Rotman [
|ran ROt . 7/
 Ruby 2.3.0-p0 Rubylnstaller Team 5/1
aSkype“ 7.26 Skype Technologies S.A. Tle
& spotify Spatify AB 81
|3 SOL Server Browser for SOL Server 2014 Micresoft Corperation T/E
B Sublime Text Build 3114 Sublime HQ Pty Ltd 51
[@) Synaptics Pointing Device Driver Synaptics Incorporated IE
mSynaptlcsWEF DDK 5011 (Advanced) Synaptics 5/2
() TAP-Windows 8.21.1 W,
T -
“~_  Currently installed programs Total size: 7.69 GB
[.] 70 programs installed

3. Follow the instructions to remove the old version of the Excel RTD/API Links.

4. Install the new version of the Excel RTD/API Links that you have downloaded from
https://inside.rotman.utoronto.ca/financelab/rit-downloads/

5. After installing the new Excel RTD/API Links, open Excel and navigate to the Developer tab
and open the Visual Basic Editor.
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H - ¢ 3 i Bookl - Excel
HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW DEVELOPER ACROBAT Jeremy Chiu - m
F 29 Record Macro a"ﬂ- e ﬁ' b‘(‘ Properties es @? Impart D
— o=
u ﬁ Use Relative References o -! =" &1 View Code 3 Expansion Packs EEL Export &
lacros Add-lns  COM Insert Design urce Document
! Macro Security Add-Ins - Mode Eﬂ] Run Dialog [#1 Refresh Data Panel
Code Add-Ins Contrals XML Maodify -~
Al | S ~
A B C D E F G H J K L[]

6. On the toolbar, choose Tools > References and ensure that Rotman Interactive Trader is
checked off or add it by browsing to C:\Program Files\Rotman or C:\Program Files
(x86)\Rotman as needed.

Microsoft Visual Basic for Applications - Bookl

File Edit View |Insert Format Debug Ru

Tools | Add-lns  Window Help
EE-E LR o u € References.. |
Project - VBAProject & Additional Controls...

= ‘ ! Macros...

% atpvbaen.xls (ATPVBAEI Options...
5 Solver (SOLVERXLAM} VBAProject Properties...
B4 VBAProject (Bookl)

.55 Microsoft Excel Objects
1 Sheet1 (Sheet1)
ThisWorkbook

1 BE UD AN~k (EIMERES VI

Digital Signature...

References - VBAProject

Available References:

Visual Basic For Applications -
Microsoft Excel 15.0 Object Library

x
| Concel

OLE Automation
Microsoft Office 15.0 Object Librar

atpvbaen. xls

Microsoft Forms 2.0 Object Library
Ref Edit Control Priority
Solver
VEAProject ﬂ
VBAProject

VBAProject

AccessibilityCpladmin 1.0 Type Library
Arrnhat

Rotman Interactive Trader J
+

~ 10000000 0KIKIIK

Rotman Interactive Trader

Location:  C:‘Program Files'\Rotman\RIT x64 2.0 RTD API Link\RIT2. b
Language: Standard
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3. The RTD update (throttle) interval in Excel

Once you install the RTD Links as instructed above, you may need to set up the RTD Throttle
Interval which is the refresh rate of how often the RTD links are updated in your Excel. For
example, if the interval is set to 1000, it means that the RTD links are updated every 1000
milliseconds (which is one second). By default, most Excel versions have it set at 2000 and we
recommend setting it at 1000 for convenience and easy coding.

Please note that your instructor may have a separate recommendation for the value depending on
the type of class, and also note that making it too low (closer or equal to zero) may result in your
system crash or failure as Excel will continuously update values and run calculations.

In order to set the RTD Throttle Interval, you'll need to follow the instructions below.

Step 1
Open your Excel and click Developer - Visual Basic. If you do not have the Developer tab available

in your Excel, first ensure that it is turned on by clicking on “File” on the top-left corner of the
screen, then click on “Options”. Once the “Excel Options” window is opened, choose “Customize
Ribbon” on the left menu bar, and ensure that “Developer” on the right side is checked. Once this is
checked, the Developer Tab will appear in the original list of Excel tabs as shown below.

(x| =l | Bookl - Microsoft Excel

Home Insert Pag Exocl Ontins —Dlll
General . .
el save ﬁj Customize the Ribbon,
InfOT Formulas
Save As Choose commands fram: (i Customize the Ribbon: (i
=] Open Proofing IPopuIar Commands ;I IMain Tabs LI
el .
o _,Lt Save
[ Close =] . 'ih Al Chart Types... 4 Main Tabs
Pre angusge i--i Borders » Bl ¥ Home
Info - Work | Advanced Calculate Now Clipboard
= Center Font
(PE———— = R
Recent Customize Ribbon ﬁ Conditional Formatting 3 Alignment
L5 Connections Humber
Quick Access Toolbar 23 Copy Styles
New 4] Custom Sort... Cells
| Addins % cut Editing
Print Che Trust Center A~ Decrease Font Size ¥ Insert
= % Delete Cells... ¥ Page Layout
Save & Send }F Delete Sheet Columns ® ¥ Formulas
=" Delete Sheet Rows ¥ Data
=) E-mail — | ¥ Review " |
ElE g 3 Fill Calor N 2
=] | = Filter << Remove ([ Developer -
[z Addns - o Font i
1 Opti Vers A Font Color b = [V Acrobat
:] Options Font Size = ¥ Thomson Reuters
[ Bt 57 Format Cells... [ Background Remaval
# Format Painter
| Freeze Panes 3
A~ Increase Font Size
5= Insert Cells...
e Insert Function...
J,f Insert Sheet Columns
jﬁi Insert Sheet Rows
b Macros Mew Tab | Mew Group | Rename... |
| Merge & Center Customizations: Reset = | i
§ Mame Manager
1 MNew R4 Import/Export 'l i
0K I Cancel

s

You can access the VBA editor by clicking on the “Visual Basic” icon within the Developer tab.

Copyright © 2014, Rotman School of Management. 7



Hint: You can access this at anytime with the shortcut Alt+F11

Step 2

As shown in the screenshot below, click (1) View and choose (2) Immediate Window. You'll see a
blank window displayed at the bottom.

In this window, you can type the following command (3) in order to query the current RTD refresh
rate. As mentioned earlier, this value is usually set to 2000 by Microsoft.

? Application.RTD.Throttlelnterval
Once you hit enter, you'll see that the value is displayed below the command.

In order to change this value, simply type in the following command (4). In this case, we're setting
the value to 1000 (millisecond) which corresponds to one second.

Application.RTD.Throttlelnterval = 1000

You may query the (3) command again to check this as shown in the screenshot below (5).

T g e -
I.-l.ul.l.uun.ub.muehu“nu - ?@
7 Sgplication.RTD.Thrsttielatesval

Lﬂw ,a

l:|le

You are now ready to use the Rotman Interactive Trader and link real-time data in Excel!
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